Another Issue on S4 -Solved on my own

  • So I've noticed yet another issue thats been around, older computers cannot run the game, even though the game is not really designed to be ran by the newest most well-performing computers out there. Ive got a good computer that opens s4 pretty quickly but once in a while I move cities for a few days where I use an older laptop, the other day I tried running S4 on my older laptop and it kept disconnecting me after the loading screen.


    Did anyone from the s4 staff ever thought that this is going to make a lot of people quit since lots of them still play s4 because their PC's might be not that new. How are you going to have a game that does not require the latest GPU and CPU, yet get it to disconnect after the loading screen?


    UPDATE WITH SOLUTION: For the people that have sht PC's and cannot run s4 because they get the disconnected message, Download Razer Game Booster and start s4 with this program, it should help and you wont be getting that message when you start the game!

  • Hi,


    is it possible that your timezone is not synced?

    If so, you should sync is as it's being shown in the Technical issues guide.


    By the way, I think this should go into the issues subforum.


    Yours,


    0xFEE1DEAD

  • Yes, it is really a problem. The loading times have been significantly increased after eac was added and on top of everything if the game doesn't load in less than 5 mins it is going to disconnect you.


    I really hope they get come with a solution for it soon.

  • If i hadn't bought a new computer (not because of S4) i'd be one of those people quiting the game.


    It's kinda laughable how a 10-year old game takes so much time to load.


    If this isn't on their highest priority , it's gonna be nice for Aeria cause they'll probably lose new players which is exactly what we need atm.

  • If i hadn't bought a new computer (not because of S4) i'd be one of those people quiting the game.


    It's kinda laughable how a 10-year old game takes so much time to load.


    If this isn't on their highest priority , it's gonna be nice for Aeria cause they'll probably lose new players which is exactly what we need atm.

    I mean it loads up really quick on my new computer, but not everyone has a good GPU and CPU, they seriously need to do something about this

  • my old pc does it (i7 920 @2.66ghz)

    and you don't need a good gpu - that one has a gts 250, and even a gt 550m (alongside some i7 XXXX QM @ 2.00ghz) can do it.

    Edit: even a 630m can do it


    Pre EAC:

    The loading times were strange and aren't really stable to me. The 1st time usually failed on my toaster-laptop while any subsequent tries worked in <1 min (still i could usually do something else when loding in for the 1st time and then proceed to the 2nd usually sucesful try).


    What toaster-level is your laptop?

  • My Toasters are this ones


    Acer Aspire E1-510

    Intel Pentium 4 Core N3520 2.17Ghz

    Intel Trash HD Graphics

    4GB RAM


    Asus X59SL (Don't Remember Very Well)

    Intel Dual-Core

    ATI Mobility Radeon HD 3470

    3GB Ram

  • can urs run on the Intel Pentium?

    Mine has an intel i3 and it ran perfectly before these newest updates lmao

  • My pc runs it perfectly cause it is a good mid range gaming pc... laptop cant run it with an i3


    fyi .... it ran s4 perfectly before these newest updates

  • I don't think the number of cores really matters. The game is so old, single core performance should be your stat.


    fyi .... it ran s4 perfectly before these newest updates

    "an i3" does not say very much. The new desktop i3 will beat older i7. I haven't read too much into it, but the i7's hyperthreading shouldn't do much when it comes to s4.


    Anyway, i guess i'll check back with my toasters some time

  • I am getting that issue on a dual core 1.73GHZ processor.

    The one that I usually play on is also dual core but at 2.40GHz and I don't have the issue there unless I am doing something else that is processor heavy.

  • Hi,

    we are indeed aware of this specific issue and we have forwarded it up to the developers to at least increase the timeout limit, if the start up couldn't be improved in a short notice (what I highly believe that it will be a harder part). For now I didn't receive any feedback about it and hopefully it can be optimized soon.

  • Update: For the people that have sht PC's and cannot run s4 because they get the disconnected message, Download Razer Game Booster and start s4 with this program, it should help and you wont be getting that message when you start the game!


    At least thats what helped me.

  • Update: For the people that have sht PC's and cannot run s4 because they get the disconnected message, Download Razer Game Booster and start s4 with this program, it should help and you wont be getting that message when you start the game!


    At least thats what helped me.

    or the game boost mode in Driver Booster

  • So I've noticed yet another issue thats been around, older computers cannot run the game, even though the game is not really designed to be ran by the newest most well-performing computers out there. Ive got a good computer that opens s4 pretty quickly but once in a while I move cities for a few days where I use an older laptop, the other day I tried running S4 on my older laptop and it kept disconnecting me after the loading screen.


    Did anyone from the s4 staff ever thought that this is going to make a lot of people quit since lots of them still play s4 because their PC's might be not that new. How are you going to have a game that does not require the latest GPU and CPU, yet get it to disconnect after the loading screen?


    UPDATE WITH SOLUTION: For the people that have sht PC's and cannot run s4 because they get the disconnected message, Download Razer Game Booster and start s4 with this program, it should help and you wont be getting that message when you start the game!

    how do i use s4 whit this program? i don´t know what to add, the patcher or the client

  • Y'all complaining about your "old" PC's while i'm using a low-quality HP from 2006 with no graphic card, just equipped with 2gb DDR3 RAM and a very questionable celeron.


    Oh, and 40kb/s irregular.



    Jokes aside, i really can't play since the last patch, so i doubt i will be able to do so soon.

    The only good monster is the one that is dead.

    - Goblin Slayer Veteran Hunter