Game is not opening after patching.

  • After the new anti-cheat tool whenever I try to open the game it just never appears, not even in the task manager.

    Would love to know what's going on and if there's any fix to it, thank you very much Alice5

  • Hey Gael,

    we have a possible solution on this on our discord server you might want to try.

    Problem: After the latest anticheat change patch the game isn't starting anymore and the process instantly disappears from the task manager.

    -Reinstall the game by redownloading it from the website after having the current game version uninstalled and the old installation files removed as well. The default path for the installation files is C:/AeriaGames/S4League_US

    - Add the game directory or the main game executional files to your antivirus exceptions (Issue noticed especially with the antivirus names 'Avast')
    - Enter the EasyAntiCheat directory inside your game folder and run EasyAntiCheat_Setup.exe to install or repair EAC. - Rename the file S4Client_EAC.exe into S4Client_BE.exe and replace the already existing S4Client_BE.exe file, if the above solutions didn't work.

  • Thank you for your response, I have tried your possible solutions and reinstalling the game has worked I have been able to open it without problem, albeit it still takes a lot of time to open and I end up losing connection, it does open so it is solved, I've seen a thread similar to what is going on so this thread can be closed.

    Thank you again for your help.